Original computing articles by a systems administrator

BGP-HSRP Router Configurations

Mine1:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mine1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
interface FastEthernet0/0
ip address 172.16.8.2 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.8.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
standby ip 192.168.1.1
standby priority 110
standby preempt delay reload 20
standby track FastEthernet0/0
!
router bgp 64512
no synchronization
bgp log-neighbor-changes
network 12.12.12.0 mask 255.255.255.224
neighbor 172.16.8.1 remote-as 1500
neighbor 172.16.8.1 next-hop-self
neighbor 172.16.8.1 route-map LOCALPREF in
neighbor 192.168.8.2 remote-as 64512
neighbor 192.168.8.2 next-hop-self
no auto-summary
!
ip http server
!
ip route 12.12.12.0 255.255.255.224 Null0
!
ip nat inside source static 192.168.1.5 12.12.12.5 extendable
!
!
route-map LOCALPREF permit 10
set local-preference 200
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Mine2:


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mine2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
interface FastEthernet0/0
ip address 172.16.8.6 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.8.2 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.1.3 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
standby ip 192.168.1.1
standby priority 109
standby track FastEthernet0/0
!
router bgp 64512
no synchronization
bgp log-neighbor-changes
network 12.12.12.0 mask 255.255.255.224
neighbor 172.16.8.5 remote-as 1500
neighbor 172.16.8.5 next-hop-self
neighbor 172.16.8.5 route-map AS_PATH_APPEND out
neighbor 192.168.8.1 remote-as 64512
neighbor 192.168.8.1 next-hop-self
no auto-summary
!
ip http server
!
ip route 12.12.12.0 255.255.255.224 Null0
!
ip nat inside source static 192.168.1.5 12.12.12.5 extendable
!
!
route-map AS_PATH_APPEND permit 10
set as-path prepend 64512
!
route-map LOCALPREF permit 10
set local-preference 200
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Pretend Server


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PretendServer
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
interface FastEthernet0/0
ip address 192.168.1.5 255.255.255.0
duplex auto
speed auto
!
ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Provider1


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Provider1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.8.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
!
router bgp 1500
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.2 remote-as 1500
neighbor 10.0.0.2 next-hop-self
neighbor 172.16.8.2 remote-as 64512
neighbor 172.16.8.2 default-originate
no auto-summary
!
ip http server
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Provider2


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Provider2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
interface FastEthernet0/0
ip address 172.16.8.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
router bgp 1500
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.1 remote-as 1500
neighbor 10.0.0.1 next-hop-self
neighbor 172.16.8.6 remote-as 64512
neighbor 172.16.8.6 default-originate
no auto-summary
!
ip http server
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end